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This user guide describes how to use the National Instruments USB-6001/6002/6003 data
acquisition (DAQ) devices. For device specifications, go to ni.com/manuals and search by
device name.
The NI USB-6001/6002/6003 is a full-speed USB device that provides eight single-ended
analog input (AI) channels, which may also be configured as four differential channels. It also
includes two analog output (AO) channels, 13 digital input/output (DIO) channels, and a 32-bit
counter.
Table 1. Differences Between the NI USB-6001, NI USB-6002, and NI USB-6003

Feature

NI USB-6001

NI USB-6002

NI USB-6003

Analog Input

Analog-to-digital
converter (ADC)
Resolution

14-bit

16-bit

16-bit

Maximum Sample
Rate (aggregate)

20 kS/s

50 kS/s

100 kS/s

Analog Output

DAC Resolution

14-bit

16-bit

16-bit

Absolute Accuracy,
Typical, at full scale

9.1 mV

8.6 mV

8.6 mV

Figure 1. NI USB-6001/6002/6003 Top and Side Views
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Safety Guidelines
Operate the NI DAQ device only as described in this document.
Refer to the NI USB-6001/6002/6003 Safety, Environmental, and
Regulatory Information document included with your kit for important safety and
electromagnetic compatibility information. To obtain a copy of this document online,
visit ni.com/manuals and search for the document title.

Caution

Do not operate the device in a manner not specified in this document.
Misuse of the device can result in a hazard. You can compromise the safety protection
built into the device if the device is damaged in any way. If the device is damaged,
contact National Instruments for repair.
Caution

Do not substitute parts or modify the device except as described in this
document. Use the device only with the chassis, modules, accessories, and cables
specified in the installation instructions.
Caution

Do not operate the device in an explosive atmosphere or where there may
be flammable gases or fumes. If you must operate the device in such an environment,
it must be in a suitably rated enclosure.

Caution

Caution You must have all covers and filler panels installed during operation of the
device. Do not operate the device without verifying that the cover is correctly
attached and the device is completely closed.
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Electromagnetic Compatibility Guidelines
This product was tested and complies with the regulatory requirements and limits for
electromagnetic compatibility (EMC) stated in the product specifications. These requirements
and limits provide reasonable protection against harmful interference when the product is
operated in the intended operational electromagnetic environment.
This product is intended for use in industrial locations. However, harmful interference may
occur in some installations, when the product is connected to a peripheral device or test object,
or if the product is used in residential or commercial areas. To minimize interference with radio
and television reception and prevent unacceptable performance degradation, install and use this
product in strict accordance with the instructions in the product documentation.
Furthermore, any modifications to the product not expressly approved by National Instruments
could void your authority to operate it under your local regulatory rules.
To ensure the specified EMC performance, the length of any wire or cable
connected to the screw terminal connector must be no longer than 0.5 m (20 in.).
Caution

Unpacking
The NI DAQ device ships in an antistatic package to prevent electrostatic discharge (ESD). ESD
can damage several components on the device.
Caution

Never touch the exposed pins of the connectors.

To avoid ESD damage in handling the device, take the following precautions:
•

Ground yourself with a grounding strap or by touching a grounded object.

•

Touch the antistatic package to a metal part of your computer chassis before removing the
device from the package.

Remove the device from the package and inspect it for loose components or any other signs of
damage. Notify NI if the device appears damaged in any way. Do not install a damaged device
in your computer.
Store the device in the antistatic package when the device is not in use.

Packing List
The NI DAQ device is shipped in a box that contains:
•

NI USB-6001/6002/6003

•

Two screw terminal connector plugs

•

Hi-Speed Micro USB cable

•

NI-DAQmx DVD

•

NI USB-6001/6002/6003 Quick Start document

•

NI USB-6001/6002/6003 Safety, Environmental, and Regulatory Information document
NI USB-6001/6002/6003 User Guide
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Setting Up the NI USB-6001/6002/6003
Complete the following steps to get started with the NI USB-6001/6002/6003.

Installing the Software
1.

Install the application software (if applicable), as described in the installation instructions
that accompany your software.

2.

Install NI-DAQmx. NI USB-6001/6002/6003 devices are supported by NI-DAQmx 9.9 and
later.
Note The NI-DAQmx software is included on the disk shipped with your kit and is
available for download at ni.com/support. The documentation for NI-DAQmx is
available after installation from Start»All Programs»National Instruments»
NI-DAQmx. Other NI documentation is available at ni.com/manuals.

3.

Register your products when the NI Product Registration Wizard appears.

Preparing the Hardware
1.

Insert the screw terminal connector plugs into the connector jacks on the device. Refer to
Figure 2.

2.

The Hi-Speed Micro USB cable has two different connectors. Plug the smaller connector
into the device, and plug the larger connector into the USB port on the computer where
NI-DAQmx is installed.
Figure 2. Hardware Setup for NI USB-6001/6002/6003
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2

Hi-Speed Micro USB Cable

Verifying the Installation
1.

Complete the following to launch NI Measurement and & Automation Explorer (NI MAX):
•

(Windows 7/Vista)—Double-click the NI MAX icon on the desktop.

•

(Windows 8)—Click NI Measurement & Automation Explorer from NI Launcher.

2.

Expand My System»Devices and Interfaces and verify that the NI USB-6001/6002/6003
is listed. If your device does not appear, press <F5> to refresh the view in NI MAX. If your
device is still not recognized, refer to ni.com/support/daqmx for troubleshooting
information.

3.

To self-test your device in NI MAX, right-click your device and select Self-Test. Self-test
performs a brief test to determine successful device installation. When the self-test finishes,
a message indicates successful verification. If an error occurs, refer to ni.com/support/
daqmx.
To ensure the specified EMC performance, operate this product only with
shielded cables and accessories.

Caution

4.

Connect the wires (0.08 to 1.31 mm2 [28 to 16 AWG]) of a shielded, multiconductor cable
to the screw terminals by stripping 6 mm (0.25 in.) of the insulation, inserting the stripped
wires into the screw terminals, and securely tightening the screws with a flathead
screwdriver to a torque of 0.22 to 0.25 N · m (2.0 to 2.2 lb · in.). Refer to Figure 4 for the
NI USB-6001/6002/6003 pinout.
If using a shielded cable, connect the cable shield to a nearby GND terminal.

5.

Run a test panel in NI MAX by right-clicking your device and selecting Test Panels.
Click Start to test the device functions, or Help for operating instructions. If an error
message occurs refer to ni.com/support/daqmx. Click Close to exit the test panel.

Using the NI USB-6001/6002/6003 in an
Application
Example Programs
NI-DAQmx driver software includes example programs to help you get started programming
with the NI USB-6001/6002/6003. You can modify example code and save it in an application,
use examples to develop a new application, or add example code to an existing application.
To locate NI software examples, go to ni.com/info and enter the Info Code daqmxexp.
To run examples without the device installed, use an NI-DAQmx simulated device. For more
information, open NI Measurement & Automation Explorer (NI MAX), select Help»Help
Topics»NI-DAQmx»MAX Help for NI-DAQmx, and search for simulated devices.

NI USB-6001/6002/6003 User Guide
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NI-DAQ Assistant
You can use the NI-DAQ Assistant through many NI application software programs to configure
virtual and measurement channels. Table 2 lists NI-DAQ Assistant tutorial locations for
NI applications.
Table 2. NI-DAQ Assistant Tutorial Locations

NI Application
Software

Tutorial Location

LabVIEW

Go to Start»All Programs»National Instruments»
NI-DAQmx»NI-DAQmx Help»Getting Started.

LabWindows™/CVI™

Go to Help»Contents. Next, go to Using LabWindows/CVI»
Data Acquisition»Taking an NI-DAQmx Measurement in
LabWindows/CVI.

Measurement Studio

Go to NI Measurement Studio Help»Getting Started with the
Measurement Studio Class Libraries»Measurement Studio
Walkthroughs»Walkthrough: Creating a Measurement Studio
NI-DAQmx Application.

SignalExpress

Go to Help»Taking an NI-DAQmx Measurement in
SignalExpress.

ANSI C without NI Application Software
The NI-DAQmx Help contains API overviews and general information about measurement
concepts. Select Start»All Programs»National Instruments»NI-DAQmx»NI-DAQmx Help.
The NI-DAQmx C Reference Help describes the NI-DAQmx Library functions. Select Start»
All Programs»National Instruments»NI-DAQmx» Text-Based Code Support»NI-DAQmx
C Reference Help.

.NET Languages without NI Application Software
With the Microsoft .NET Framework version 2.0 or later, you can use NI-DAQmx to create
applications using Visual C# and Visual Basic .NET without Measurement Studio. You need
Microsoft Visual Studio .NET 2005 or later for the API documentation to be installed.
The installed documentation contains the NI-DAQmx API overview, measurement tasks and
concepts, and function reference. To view the NI-DAQmx .NET documentation, go to Start»
All Programs»National Instruments»NI-DAQmx»Text-Based Code Support. For function
reference, refer to the NationalInstruments.DAQmx Namespace and NationalInstruments.
DAQmx.ComponentModel Namespace topics. For conceptual help, refer to the Using the
Measurement Studio NI-DAQmx .NET Library and Developing with Measurement Studio
NI-DAQmx sections.
To get to the same help topics from within Visual Studio 2005 or 2008, go to Help»Contents
and select Measurement Studio from the Filtered By drop-down list. To get to the same help
topics from within Visual Studio 2010, go to Help»View Help and select NI Measurement
Studio Help from the Related Links section.
6
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Features
Block Diagram
Figure 3 shows key functional components of the NI DAQ device.
Figure 3. NI USB-6001/6002/6003 Block Diagram
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LED Indicator
The NI DAQ device has a blue LED that indicates device status, as listed in Table 3.
Table 3. LED State/Device Status

LED State

Device Status

Off

Device is not connected or is in suspend mode.

On, not blinking

Device is connected and functioning normally.

Blinking

Device has encountered an error. Wait 10 seconds to allow the
device to attempt to recover from the error. If the LED
continues blinking, disconnect and reconnect the device. If
the error persists, contact National Instruments. Refer to the
Worldwide Support and Services section for contact
information.

Screw Terminal Connector Plugs
The NI USB-6001/6002/6003 ships with two detachable screw terminal connector plugs: one for
analog signals and one for digital signals. These screw terminal connectors provide
16 connections that use 0.08 to 1.31 mm2 (28 to 16 AWG). Refer to the Pinout and Signal
Descriptions section for the device pinout and signal descriptions.

Cables and Accessories
Table 4 contains information about cables and accessories available for the
NI USB-6001/6002/6003. For a complete list of accessories and ordering information, refer to
the pricing section of the NI DAQ device product page at ni.com.
Table 4. NI USB-6001/6002/6003 Cables and Accessories

Accessory

Part Number

Description

USB-600x Accessories

782703-01

Four additional screw-terminal connectors
and a screwdriver.

USB-600x Series
Prototyping Accessories

779511-01

Unshielded breadboarding accessory for
custom-defined signal conditioning and
prototyping. You can use up to
two accessories per device.

Hi-Speed Micro USB
Cable, A to Micro-B

782909-01,
782909-02

1 m and 2 m lengths

Caution: To ensure the specified EMC performance, the length of any wire or cable
connected to the screw terminal connector must be no longer than 0.5 m (20 in.).
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Pinout and Signal Descriptions
Figure 4 shows the NI DAQ device pinout. Analog input signal names are listed as single-ended
analog input name, AI x, and then the differential analog input name, (AI x+/-). Refer to Table 5
for a detailed description of each signal.
Figure 4. NI USB-6001/6002/6003 Pinout
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Table 5. Signal Descriptions

Signal
Name

Reference

Direction

AI GND

—

—

AI <0..7>

AI GND

Input

Description

Analog Input Ground—The reference point
for single-ended analog input measurements.
Analog Input Channels 0 to 7—For
single-ended measurements, each signal
corresponds to one analog input voltage channel.
For differential measurements, AI 0 and AI 4 are
the positive and negative inputs of differential
analog input channel 0. The following signal
pairs also form differential input channels:
AI <1,5>, AI <2, 6>, and AI <3, 7>. Refer to the
Analog Input section for more information.
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Table 5. Signal Descriptions (Continued)

Signal
Name

Reference

Direction

Description

AO GND

—

—

Analog Output Ground—The reference point
for analog output.

AO <0, 1>

AO GND

Output

Analog Output Channels 0 and 1—Supplies
the voltage output of the AO channels. Refer to
the Analog Output section for more information.

P0.<0..7>

D GND

Input or
Output

Port 0 Digital I/O Channels 0 to 7—You can
configure each signal individually as an input or
output. Refer to the Digital I/O section for more
information.

P1.<0..3>

D GND

Input or
Output

Port 1 Digital I/O Channels 0 to 3—You can
configure each signal individually as an input or
output. Refer to the Digital I/O section for more
information.

P2.0

D GND

Input or
Output

Port 2 Digital I/O Channel 0—You can
configure each signal individually as an input or
output. Refer to the Digital I/O section for more
information.

PFI 0, 1

D GND

Input

Programmable Function Interface or Digital
I/O Channels—An edge counter input or digital
trigger input. Refer to the PFI 0 and PFI 1
section for more information.

D GND

—

—

Digital Ground—The reference point for digital
signals.

D GND

Output

+5 V Power Source—Provides +5 V power up
to 150 mA. Refer to the +5 V Power Source
section for more information.

+5 V
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Analog Input
The NI USB-6001/6002/6003 has eight analog input channels that you can use for four
differential analog input measurements or eight single-ended analog input measurements.
Figure 5 shows the analog input circuitry of the NI DAQ device.
Figure 5. NI USB-6001/6002/6003 Analog Input Circuitry
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The main blocks featured in the analog input circuitry are as follows:
•

MUX—The multiplexer (MUX) routes one AI channel at a time to the mode selector
multiplexer (DIFF/RSE MUX).

•

DIFF/RSE MUX—The mode selector multiplexer selects between differential mode
(DIFF) and referenced single-ended (RSE) measurement mode.

•

IA— The instrumentation amplifier (IA) removes the common mode signal and buffers the
analog input signal before it is sampled by the analog-to-digital converter (ADC).

•

ADC—The analog-to-digital converter (ADC) digitizes the AI signal by converting the
analog voltage into digital code.

•

AI FIFO—The NI DAQ device can perform both single and multiple analog-to-digital
conversions of a fixed or infinite number of samples. A first-in-first-out (FIFO) buffer
holds data during AI acquisitions to ensure no data is lost.

•

ADC Control—The ADC control circuitry sets the conversion rate of the ADC, sets the
input configuration, drives the scanning sequence, and starts acquisitions synchronous with
PFI 0 or PFI 1.

NI USB-6001/6002/6003 User Guide
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Analog Input Modes
You can configure the analog input channels on the NI DAQ device to take up to four differential
(DIFF) or eight referenced single-ended (RSE) measurements.
•

Differential mode—In DIFF mode, the NI DAQ device measures the difference in voltage
between two AI signals.

•

Referenced single-ended mode—In RSE mode, the NI DAQ device measures the voltage
of an AI signal relative to AI GND.

Analog input modes are programmed on a per-channel basis. For example, you can configure
the device to scan two channels in differential mode and four channels on single-ended mode.
The AI settings determine how you connect your AI signals to the NI DAQ device.

Taking Differential Measurements
For differential signals, connect the positive lead of the voltage signal or source to the
AI+ terminal, and the negative lead to the AI- terminal.
Figure 6. Connecting a Differential Voltage Signal
AI+
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DAQ Device

AI–

Figure 7. Example of a Differential ±10 V Measurement
10

Amplitude (V)

5

0
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–10
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AI 1
AI 5
Result

Taking Referenced Single-Ended Measurements
To connect referenced single-ended (RSE) voltage signals to the NI DAQ device, connect the
positive voltage signal to an AI terminal, and the ground signal to a AI GND terminal, as shown
in Figure 8.
Figure 8. Connecting a Referenced Single-Ended Voltage Signal
AI

Voltage
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AI GND

NI USB-6001/6002/6003 User Guide

|

© National Instruments

|

13

Signal Sources and Recommended Input Configuration
Table 6 summarizes the recommended analog input mode(s) for floating signal sources and
ground-referenced signal sources.
Table 6. NI USB-6001/6002/6003 Analog Input Configuration

Signal Source Type
Analog Input Mode*

Floating Signal Source
(Not Connected to
Building Ground)

Examples:
• Ungrounded
thermocouples
• Signal conditioning with
isolated outputs
• Battery devices
Differential (DIFF)

Signal Source

DAQ Device
AI+

+
–

AI–

Ground-Referenced
Signal Source†

Example:
• Plug-in instruments with
non-isolated outputs

DAQ Device

Signal Source

AI+

+

+
–

–

AI GND

AI–

+
–

AI GND

Vcm

Referenced
Single-Ended (RSE)
Signal Source

DAQ Device
AI

+
–

Signal Source

DAQ Device

+

AI

+
–

–

AI GND

VA

+
–

VB

AI GND

Ground-loop potential (VA – VB) are added
to measured signal.
* Refer to the Taking Differential Measurements section for descriptions of the RSE and DIFF modes
and software considerations.
†
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Floating Signal Sources
An instrument or device that has an isolated output is a floating signal source. A floating signal
source is not connected to the building ground system, but has an isolated ground-reference
point. Some examples of floating signal sources are outputs of transformers, thermocouples,
battery-powered devices, optical isolators, and isolation amplifiers.
For more information about field wiring and noise considerations for analog signals, go to
ni.com/info and enter Info Code rdfwn3.

When to Use Differential Connections with Floating Signal Sources
Use DIFF input connections for any channel that meets any of the following conditions:
•

The input signal is low level and requires greater accuracy.

•

The leads connecting the signal to the device are greater than 3 m (10 ft).

•

The input signal requires a separate ground-reference point or return signal.

•

The signal leads travel through noisy environments.

•

Two analog input channels, AI+ and AI-, are available for the signal.

DIFF signal connections reduce noise pickup and increase common-mode noise rejection. DIFF
signal connections also allow input signals to float within the working voltage of the device.
With this type of connection, the instrumentation amplifier (IA) rejects both the common-mode
noise in the signal and the ground potential difference between the signal source and the device
ground.
Refer to the Taking Differential Measurements section for more information about differential
connections.

When to Use Referenced Single-Ended (RSE) Connections with Floating
Signal Sources
Only use RSE input connections if the input signal meets all of the following conditions:
•

The input signal can share a common reference point, AI GND, with other signals that use
RSE.

•

The leads connecting the signal to the device are less than 3 m (10 ft).

DIFF input connections are recommended for greater signal integrity for any input signal that
does not meet the preceding conditions.
In the single-ended modes, more electrostatic and magnetic noise couples into the signal
connections than in DIFF configurations. The coupling is the result of differences in the signal
path. Magnetic coupling is proportional to the area between the two signal conductors. Electrical
coupling is a function of how much the electric field differs between the two conductors.
Refer to the Taking Referenced Single-Ended Measurements section for more information about
RSE connections.
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Ground-Referenced Signal Sources
A ground-referenced signal source is a signal source connected to the building system ground.
It is already connected to a common ground point with respect to the device, assuming that the
computer is plugged into the same power system as the source. Non-isolated outputs of
instruments and devices that plug into the building power system fall into this category.
The difference in ground potential between two instruments connected to the same building
power system is typically between 1 and 100 mV, but the difference can be much higher if power
distribution circuits are improperly connected. If a grounded signal source is incorrectly
measured, this difference can appear as measurement error. Follow the connection instructions
for grounded signal sources to eliminate this ground potential difference from the measured
signal.
For more information about field wiring and noise considerations for analog signals, go to
ni.com/info and enter Info Code rdfwn3.

When to Use Differential Connections with Ground-Referenced Signal
Sources
Use DIFF input connections for any channel that meets any of the following conditions:
•

The input signal is low level and requires greater accuracy.

•

The leads connecting the signal to the device are greater than 3 m (10 ft).

•

The input signal requires a separate ground-reference point or return signal.

•

The signal leads travel through noisy environments.

•

Two analog input channels, AI+ and AI-, are available for the signal.

DIFF signal connections reduce noise pickup and increase common-mode noise rejection. DIFF
signal connections also allow input signals to float within the working voltage of the device.
Refer to the Taking Differential Measurements section for more information about differential
connections.

When to Use Referenced Single-Ended (RSE) Connections with
Ground-Referenced Signal Sources
Do not use RSE connections with ground-referenced signal sources. Use differential
connections instead.
As shown in the bottom right cell of Table 6, there can be a potential difference between AI GND
and the ground of the sensor. In RSE mode, this ground loop causes measurement errors.
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Input Range
The NI DAQ device has an input range of ±10 V. For differential mode, each AI should stay
within ±10 V with respect to AI GND, and the voltage between positive and negative inputs
should be lower or equal to ±10 V. For RSE mode, signals of ±10 V at any analog input terminal
with respect to AI GND are accurately measured.
Figure 9. Analog Input Range
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+
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+
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–
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Beyond ±10 V, the input signal begins clipping as shown in Figure 10. Typically, this clipping
begins at ±10.5 V.
Figure 10. Exceeding ±10 V on AI Returns Clipped Results
20
AI 1
Result

Amplitude (V)

10.5

0
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–20

When no signals are connected to the analog input terminal, the input could be anywhere
between +10.5 V and -10.5 V or may rail to ±10.5 V. This behavior is normal and does not affect
the measurement when a signal is connected. For more information about field and wiring noise
considerations for analog signals, go to ni.com/info and enter Info Code rdfwn3.
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Multichannel Scanning Considerations
The NI DAQ device can scan multiple channels at high rates and digitize the signals accurately.
However, you should consider several issues when designing your measurement system to
ensure the high accuracy of your measurements.
•

Use Low Impedance Sources—To ensure fast settling times, your signal sources should
have an impedance of <1 kΩ. Large source impedances increase the settling time of the
NI DAQ device and decrease the accuracy at fast scanning rates. For more information
about decreasing the source impedance of an analog signal, go to ni.com/info and enter
the Info Code rdbbis.

•

Use Short High-Quality Cabling—Using short high-quality cables can minimize several
effects that degrade accuracy including crosstalk, transmission line effects, and noise. The
capacitance of the cable also can increase the settling time.

•

Avoid Scanning Faster Than Necessary—Design your system to scan at slower speeds
to give the NI DAQ device more time to settle to a more accurate level when switching
between channels.

AI Start Trigger
You can configure PFI 0 or PFI 1 as the AI Start Trigger for analog input tasks. Refer to the
Using PFI to Trigger an Analog Input Acquisition section for more information.

Analog Output
Figure 11 shows the analog output circuitry of the NI USB-6001/6002/6003.
Figure 11. Analog Output Circuitry
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DAC 1

AO Data

The main blocks of the AO circuitry are as follows:
•

Protection—The protection circuit prevents damage of the buffers in case of a short circuit
or an overvoltage condition.

•

Buffer—The buffer amplifies the analog signal to the ±10 V range and ensures the driving
capability for the external load.

•

DAC 0 and DAC 1—The Digital to Analog Converters (DAC) convert the digital signals
into low-level analog signals.

•

AO FIFO—The AO FIFO (first-in-first out) ensures that data is transferred to the DACs
in a timely manner without being affected by USB latencies.

•

DAC Control—The DAC control sets the DAC data rate and the startup condition, which
could be triggered by PFI 0 or PFI 1.

Connecting Analog Output Signals
The analog output signals are referenced to AO GND. Connect the loads between AO 0 or AO 1
and AO GND.
Figure 12. Connecting the Analog Ouput Loads
Analog Output Channels

AO 0
+
Load

Channel 0

V OUT
–

AO GND

–
Load

V OUT
AO 1

Channel 1

+

DAQ Device

Power-On State
The AO exhibits a short glitch when the device is powered on and when the NI DAQ dev ice
exits suspend mode. After power-up, the AO is reset to 0 V.

AO Range
The AO range is ± 10 V.
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Minimizing Glitches on the Output Signal
When using a DAC to generate a waveform, you may observe glitches on the output signal.
These glitches are normal; when a DAC switches from one voltage to another, it produces
glitches due to released charges. The largest glitches occur when the most significant bit of the
DAC code changes. You can build a lowpass deglitching filter to remove some of these glitches,
depending on the frequency and nature of the output signal. Visit ni.com/support for more
information about minimizing glitches.

Analog Output Data Generation Methods
When performing an analog output operation, you can perform software-timed or
hardware-timed generations:
•

Software-Timed Generations—Software controls the rate at which data is generated.
Software sends a separate command to the hardware to initiate each NI DAQ conversion.
In DAQmx, software-timed generations are referred to as on-demand timing.
Software-timed generations are also referred to as immediate or static operations. They are
typically used for writing a single value out, such as a constant DC voltage.

•

Hardware-Timed Generations—A digital hardware signal controls the generation rate.
This signal is generated internally on your device. Hardware-timed generations have
several advantages over software-timed acquisitions:
–

The time between samples can be much shorter.

–

The timing between samples can be deterministic.

Hardware-timed operations are buffered. During hardware-timed AO generation, data is moved
from a PC buffer to the onboard FIFO on the NI DAQ device using USB signal streams before
it is written to the DACs one sample at a time. Buffered generations allow for fast transfer rates
because data is moved in large blocks rather than one point at a time.
One property of buffered I/O operations is the sample mode. The sample mode can be either
finite or continuous:
•

Finite sample mode generation refers to the generation of a specific, predetermined number
of data samples. After the specified number of samples is written out, the generation stops.

•

Continuous generation refers to the generation of an unspecified number of samples.
Instead of generating a set number of data samples and stopping, a continuous generation
continues until you stop the generation.

AO Start Trigger
You can configure PFI 1 or PFI 0 as the AO Start Trigger for analog output tasks. Refer to the
Using PFI to Trigger an Analog Output Generation section for more information.
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Digital I/O
The NI USB-6001/6002/6003 has 13 digital lines: P0.<0..7>, P1. <0..3>, and P2.0. D GND is
the ground-reference signal for digital I/O. You can individually program each line as input or
output.
All digital input and digital output updates and samples are software-timed.
Figure 13 shows P0.<0..7> connected to example signals configured as digital inputs and digital
outputs. You can configure P1.<0..3> and P2.0 similarly.
Figure 13. Example of Connecting a Load
+5 V
1
LED
P0.0
P0.1
P0.2
P0.3
P0.4
P0.5
P0.6
P0.7

LED
2
3
TTL Signal

+5 V

4
Switch

GND
I/O Connector
DAQ Device
1
2
3
4

P0.0 configured as an open collector digital output driving a LED
P0.2 configured as an active drive digital output driving an LED
P0.4 configured as a digital input receiving a TTL signal from a gated inverter
P0.7 configured as an digital input receiving a 0 V or 5 V signal from a switch

Exceeding the maximum input voltage ratings or maximum output
ratings, which are listed in the specifications document for the device, can damage
the device and the computer. National Instruments is not liable for any damage
resulting from such signal connections. For more information, refer to the device
specifications available at ni.com/manuals.
Caution

Power-On States
At system startup and reset, the hardware sets all DIO lines to high-impedance inputs. The
NI DAQ device does not drive the signal high or low. Each line has a weak pull-down resistor
connected to it.
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Source/Sink Information
When used in output mode, the default configuration of the digital ports is active drive, allowing
3.3 V operation with a source/sink current limit of ±4 mA.
The ports can be configured as open collector using the NI-DAQmx API, allowing operation
with a different voltage level when used in conjunction with an external user-provided pull-up
resistor. Figure 14 shows an example of this connection.
Figure 14. Example of Connecting an External User-Provided Resistor
Vpull-up
(User Provided, ≤5 V)

External
Pull-Up
Resistor
Rpull

External
Load

P0.0 with Output Drive Type
Set to Open Collector

47 Ω
Protection
Resistor

47.5 kΩ
Onboard
Pull-Down
Resistor

DAQ Device
Note: Ensure that the current flowing across Rpull does not violate the maximum sinking current specifications
(4 mA).

For more information about configuring NI devices to be open-drain (open collector) or
push-pull (active drive), go to ni.com/info and enter Info Code ex52sp.

I/O Protection
To protect the NI DAQ device against overvoltage, undervoltage, and overcurrent conditions, as
well as ESD events, you should avoid these fault conditions by using the following guidelines:
•

If you configure a DIO line as an output, do not connect it to any external signal source,
ground signal, or power supply.

•

If you configure a DIO line as an output, understand the current requirements of the load
connected to these signals. Do not exceed the specified current output limits of the
NI DAQ device. National Instruments has several signal conditioning solutions for digital
applications requiring high-current drive.

•

If you configure a DIO line as an input, do not drive the line with voltages outside of its
normal operating range. The DIO lines have a smaller operating range than the AI signals.

•

Treat the NI DAQ device as you would treat any static-sensitive device. Always properly
ground yourself and the equipment when handling the NI DAQ device or connecting to it.
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PFI 0 and PFI 1
Using PFI as a Counter Source
You can configure PFI 0 or PFI 1 as a source for counting digital edges. In this mode, either
rising- or falling-edges are counted using a 32-bit counter. For more information, refer to the
device specifications document available at ni.com/manuals.
Note Edges can only be counted up from either 0 or an initial value such as 1, 2,
3...or 1001, 1002, 1003. Counting down is not supported; you cannot set the initial
count to 100 and count down 99, 98, 97.

Using PFI to Trigger an Analog Input Acquisition
You can configure an analog input task to wait for an edge on PFI 0 or PFI 1 before starting the
acquisition. To do this, configure the AI Start Trigger source to be PFI 0 or PFI 1 and specify
either rising or falling edge.

Using PFI to Trigger an Analog Output Generation
You can configure an analog output task to wait for an edge on PFI 0 or PFI 1 before starting the
acquisition. To do this, configure the AO Start Trigger source to be PFI 0 or PFI 1 and specify
either rising- or falling-edge.

+5 V Power Source
Figure 15 shows the +5 V power source circuitry of the NI USB-6001/6002/6003.

I/O Connector

Figure 15. +5 V Power Source Circuitry

+5 V

+5 V
Protection

To USB
Connector

+5 V
Source

D GND

16-Position
Screw Terminal
Plug

The main blocks featured in the +5 V power source circuitry are as follows:
•

+5 V Source—Regulated 5 V supply.

•

+5 V Protection—Circuit for overvoltage, over current, and short circuit protection.

The +5 V source is limited at 200 mA typically. In case of hard short circuit to ground, this limit
is further reduced to avoid excessive power dissipation.
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Connecting the Load
The return terminal for the +5 V source is the D GND terminal. +5 V load should be connected
between the +5 V terminal and D GND. The current delivered by the NI DAQ device at the +5 V
terminal is sourced from the USB connector. To meet the USB specifications, a maximum of
150 mA can be used from the +5 V terminal.
Figure 16. Connecting +5 V Power Source Load
Optional
Capacitor
+5 V

Load

D GND
16-Position
Screw Terminal
Plug

Enable +5 V Power Source
The + 5 V power is always enabled and the voltage is present at the +5 V terminal when the
device is in active mode. The +5 V power source is not available for about one second after the
NI DAQ device is first connected to the USB connector or when the device is in suspend mode.

Related Documentation
The most recent versions of documents are available from ni.com/manuals.
The following references to documents assume you have NI-DAQmx 9.9 or later and, where
applicable, version 8.5 or later of the NI application software.

Examples
To locate NI software examples, go to ni.com/info and enter the Info Code daqmxexp.

NI USB-6001/6002/6003
The NI USB-6001/6002/6003 Quick Start packaged with your NI DAQ device describes how to
install the device and confirm that your device is operating properly.
The NI USB-6001 Specifications, NI USB-6002 Specifications, and NI USB-6003 Specifications
are available for download from ni.com/manuals.
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NI-DAQmx
The NI-DAQmx Readme lists which devices, Application Development Environments (ADEs),
and NI application software are supported by your version of NI-DAQmx. To access the
NI-DAQmx Readme, select Start»All Programs»National Instruments»NI-DAQmx»
NI-DAQmx Readme.
The NI-DAQmx Help contains API and NI-DAQmx concepts, and applications. To access the
NI-DAQmx Help, select Start»All Programs»National Instruments»NI-DAQmx»
NI-DAQmx Help.

LabVIEW
If you are a new user, go to ni.com/gettingstarted.
Use the LabVIEW Help, available by selecting Help»LabVIEW Help in LabVIEW, to access
information about LabVIEW programming concepts. Refer to the following locations on the
Contents tab of the LabVIEW Help for information about NI-DAQmx:
•

Start»National Instruments»NI-DAQmx»NI-DAQmx Help»
Getting Started—Includes overview information and a tutorial about how to take an
NI-DAQmx measurement in LabVIEW using the NI-DAQ Assistant.

•

VI and Function Reference»Measurement I/O VIs and Functions»DAQmx - Data
Acquisition VIs and Functions—Describes the LabVIEW NI-DAQmx VIs and functions.

•

Property and Method Reference»NI-DAQmx Properties contains the property
reference.

•

Taking Measurements—Contains the conceptual and how-to information you need to
acquire and analyze measurement data in LabVIEW.

LabWindows/CVI
The Data Acquisition book of the LabWindows/CVI Help contains Taking an NI-DAQmx
Measurement in LabWindows/CVI, which contains instructions about creating a measurement
task using the NI-DAQ Assistant. In LabWindows/CVI, select Help»Contents, then select
Using LabWindows/CVI»Data Acquisition.
The NI-DAQmx Library book of the LabWindows/CVI Help contains API overviews and
function reference for NI-DAQmx. Select Library Reference»NI-DAQmx Library in the
LabWindows/CVI Help.

Measurement Studio
If you program your NI-DAQmx-supported device in Measurement Studio using Visual C# or
Visual Basic .NET, you can create channels and tasks by launching the NI-DAQ Assistant from
NI MAX or from within Visual Studio. You can use Measurement Studio to generate the
configuration code based on your task or channel. Refer to the DAQ Assistant Help for
additional information about generating code.
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To view the NI Measurement Studio Help in Visual Studio, select Measurement Studio»
NI Measurement Studio Help. For information related to developing with NI-DAQmx, refer
to the following topics within the NI Measurement Studio Help:
•

To create an NI-DAQmx application using the Measurement Studio Application Wizard
and the NI-DAQ Assistant, refer to Walkthrough: Creating a Measurement Studio
NI-DAQmx Application.

•

For help with NI-DAQmx methods and properties, refer to NationalInstruments.DAQmx
Namespace and NationalInstruments.DAQmx.ComponentModel Namespace.

•

For conceptual help with NI-DAQmx, refer to Using the Measurement Studio NI-DAQmx
.NET Library and Developing with Measurement Studio NI-DAQmx.

•

For general help with programming in Measurement Studio, refer to Getting Started with
the Measurement Studio Class Libraries.

To create an application in Visual Basic .NET or Visual C#, follow these general steps:
1.

In Visual Studio, select File»New»Project to launch the New Project dialog box.

2.

In the Project types pane, expand the Visual Basic or Visual C# node, depending on which
language you want to create the project in, and select Measurement Studio.

3.

Choose a project type. You add NI DAQ tasks as a part of this step.

ANSI C without NI Application Software
The NI-DAQmx Help contains API overviews and general information about measurement
concepts. Select Start»All Programs»National Instruments»NI-DAQmx»NI-DAQmx Help.
The NI-DAQmx C Reference Help describes the NI-DAQmx Library functions, which you can
use with National Instruments data acquisition devices to develop instrumentation, acquisition,
and control applications. Select Start»All Programs»National Instruments»NI-DAQmx»
Text-Based Code Support»NI-DAQmx C Reference Help.

.NET Languages without NI Application Software
With the Microsoft .NET Framework version 2.0 or later, you can use NI-DAQmx to create
applications using Visual C# and Visual Basic .NET without Measurement Studio. You need
Microsoft Visual Studio .NET 2005 or later for the API documentation to be installed.
The installed documentation contains the NI-DAQmx API overview, measurement tasks and
concepts, and function reference. To view the NI-DAQmx .NET documentation, go to Start»
All Programs»National Instruments»NI-DAQmx» Text-Based Code Support. For function
reference, refer to the NationalInstruments.DAQmx Namespace and NationalInstruments.
DAQmx.ComponentModel Namespace topics. For conceptual help, refer to the Using the
Measurement Studio NI-DAQmx .NET Library and Developing with Measurement Studio
NI-DAQmx sections.
To get to the same help topics from within Visual Studio 2005 or 2008, go to Help»Contents
and select Measurement Studio from the Filtered By drop-down list. To get to the same help
topics from within Visual Studio 2010, go to Help»View Help and select NI Measurement
Studio Help from the Related Links section.
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Training Courses
If you need more help getting started developing an application with NI products, NI offers
training courses. To enroll in a course or obtain a detailed course outline, refer to ni.com/
training.

Technical Support on the Web
For additional support, refer to ni.com/support.
Many NI DAQ specifications and user guides are available as PDFs. You must have Adobe
Reader 7.0 or later (PDF 1.6 or later) installed to view the PDFs. Refer to the Adobe Systems
Incorporated Web site at www.adobe.com to download Acrobat Reader. Refer to the National
Instruments Product Manuals Library at ni.com/manuals for updated documentation
resources.

Worldwide Support and Services
The National Instruments website is your complete resource for technical support. At ni.com/
support you have access to everything from troubleshooting and application development
self-help resources to email and phone assistance from NI Application Engineers.
Visit ni.com/services for NI Factory Installation Services, repairs, extended warranty, and
other services.
Visit ni.com/register to register your National Instruments product. Product registration
facilitates technical support and ensures that you receive important information updates from NI.
A Declaration of Conformity (DoC) is our claim of compliance with the Council of the European
Communities using the manufacturer’s declaration of conformity. This system affords the user
protection for electromagnetic compatibility (EMC) and product safety. You can obtain the DoC
for your product by visiting ni.com/certification. If your product supports calibration,
you can obtain the calibration certificate for your product at ni.com/calibration.
National Instruments corporate headquarters is located at 11500 North Mopac Expressway,
Austin, Texas, 78759-3504. National Instruments also has offices located around the world. For
telephone support in the United States, create your service request at ni.com/support or dial
1 866 ASK MYNI (275 6964). For telephone support outside the United States, visit the
Worldwide Offices section of ni.com/niglobal to access the branch office websites, which
provide up-to-date contact information, support phone numbers, email addresses, and current
events.

Refer to the NI Trademarks and Logo Guidelines at ni.com/trademarks for more information on National Instruments trademarks. Other
product and company names mentioned herein are trademarks or trade names of their respective companies. For patents covering National
Instruments products/technology, refer to the appropriate location: Help»Patents in your software, the patents.txt file on your media, or the
National Instruments Patents Notice at ni.com/patents. You can find information about end-user license agreements (EULAs) and third-party
legal notices in the readme file for your NI product. Refer to the Export Compliance Information at ni.com/legal/export-compliance
for the National Instruments global trade compliance policy and how to obtain relevant HTS codes, ECCNs, and other import/export data. NI MAKES
NO EXPRESS OR IMPLIED WARRANTIES AS TO THE ACCURACY OF THE INFORMATION CONTAINED HEREIN AND SHALL NOT BE LIABLE FOR
ANY ERRORS. U.S. Government Customers: The data contained in this manual was developed at private expense and is subject to the applicable
limited rights and restricted data rights as set forth in FAR 52.227-14s, DFAR 252.227-7014, and DFAR 252.227-7015.
© 2014 National Instruments. All rights reserved.
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